Excel: DÜŞEYARA Fonksiyonu ile Birden Fazla Sonuç Alma

Daha önce DÜŞEYARA Fonksiyonu ile karmaşık tablolardan istediğimiz bilgiyi kolaylıkla çekmeyi öğrenmiştik  . Ancak bu bazı durum...


Daha önce DÜŞEYARA Fonksiyonu ile karmaşık tablolardan istediğimiz bilgiyi kolaylıkla çekmeyi öğrenmiştik .

Ancak bu bazı durumlarda yeterli gelmiyor. Aynı referans bilgisine bağlı birden fazla veri çekmemiz gerekebiliyor. Bu yazımızda böylesi durumlar için Excel üzerinde DÜŞEYARA ile birden fazla veri çekmenin yolunu birlikte inceleyeceğiz.


Üzerinde çalışmak için hazırladığımız örnek tablo:


Tablomuzda çeşitli şehirlerden gelen talepler listelenmiş durumdadır. Bizim Ankara'dan gelen talepleri listelemiz gerektiğini varsayacağız. Aynı şehir bilgisi birden fazla olduğu için unique bir değer elde edemiyoruz. Bu yüzden bunu kendimiz oluşturacağız. SEHIR sütununun soluna bir başka sütun oluşturacağız. Bu sütundaki hücrelere şehir bazlı sıralama yapmak için aşağıdaki fonksiyonu yazacağız. Burada daha önce anlattığımız EĞERSAY Fonksiyonunu kullanacağız. 

=EĞERSAY($C$3:C3;C3)&" "&C3

$C$3:C3 : Burası biz hücreyi aşağı çektiğimizde güncellensin ama başlangıç hücresi bozulmasın diye $ işareti kullanılarak dizayn edilmiştir. Biz fonksiyonu yaymak için aşağı çektiğimizde alttaki hücrede $C$3:C4 olacaktır. Amaç fonksiyona başlangıçtan gelinen hücreye kadar tüm hücreleri kapsatmaktır. 

Bir alttaki hücrede oluşması gereken fonksiyon =EĞERSAY($C$3:C4;C4)&" "&C4 

&" "&C3 : Bu kısım sayının yanına bir boşlukla birlikte şehir ismini getirir.


SONUÇ;


Daha sonra düşey arayı oluşturacağımız tablonun başına ekstra bir sütun getirip aşağı doğru sayılar yazacağız. Bu kısım sadece ID sütununu oluşturmak için kullanılacak. Daha kestirme bir yol da kullanılabilir.



ID sütununa =F3&" "&H3 bu fonksiyonu yazacağız. Hücreye "Soldan sayıyı al, bir boşluk bırak ve sağdan sağdan şehir ismini al birleştir" demiş oluyoruz. 
  

INDIS, ID, SEHIR sütunlarımızda fonksiyonlarımız tamamlandı. Şimdi SEHIR sütununda alt satırlara kadar ANKARA yazısını getireceğiz. ID Sütununda formülün çalışması için bunu yapmamız gerekiyor.


ID sütunundaki hücrede bulunan fonksiyonu aşağı yönlü yayabiliriz artık.


Buraya kadar yaptıklarımız DÜŞEYARA Fonksiyonunun çalışabilmesi içindi. Şimdi fonksiyonumuzu  daha önce öğrendiğimiz şekilde yazıp, fonksiyonu aşağı yönlü yayacağız.



=DÜŞEYARA(G3;B2:D14;3;0)

Burada;
G3         : Fonksiyonla oluşturduğumuz ID sütunundaki hücre
B2:B14 : ilk tablomuz
3            : ilk tabloda talep sütununun sırası

Uyarı: Bu işlemin uygularken formüllere kendi hücre numaralarınızı yazmanız gerekmektedir. İşlem sırası size karmaşık geldiyse Pivot Tablolar yoluyla sonuç almayı deneyebilirsiniz.



COMMENTS

Ad

Advanced Excel,6,Blogger Eklentileri,7,Blogger JS,2,Blogger SEO,1,CSS,1,Excel,10,Grafik,1,HDCP,1,istatistik,10,Lifehack,3,Photoshop,1,Rehber,2,Teknik Servis,1,Tools,10,Veri Analizi,10,web,15,
ltr
item
rakamlar.net: Excel: DÜŞEYARA Fonksiyonu ile Birden Fazla Sonuç Alma
Excel: DÜŞEYARA Fonksiyonu ile Birden Fazla Sonuç Alma
https://3.bp.blogspot.com/-kJCtzfghaRk/WslmNmKmZPI/AAAAAAAAD8U/shlkVvvX518iZh7RFYhp2NiC8r39rEo7ACLcBGAs/s400/2n1kexcell.jpg
https://3.bp.blogspot.com/-kJCtzfghaRk/WslmNmKmZPI/AAAAAAAAD8U/shlkVvvX518iZh7RFYhp2NiC8r39rEo7ACLcBGAs/s72-c/2n1kexcell.jpg
rakamlar.net
https://www.rakamlar.net/2018/04/excel-duseyara-ile-birdenfazla-sonuc.html
https://www.rakamlar.net/
https://www.rakamlar.net/
https://www.rakamlar.net/2018/04/excel-duseyara-ile-birdenfazla-sonuc.html
true
2335151254058832000
UTF-8
Loaded All Posts Bulunmadı Hepsini Gör Devamını Oku Reply Cancel reply Delete By Ana Sayfa Sayfalar POSTS View All RECOMMENDED FOR YOU KONU Arşiv ARA ALL POSTS Bu konuda daha önce yazmadık. Ana Sayfa Pazar Pazartesi Salı Çarşamba Perşembe Cuma Cumartesi Paz Pzts Salı Çar Per Cum Cmrts Ocak Şubat Mart Nisan Mayıs Haziran Temmuz Ağustos Eylül Ekim Kasım Aralık Oca Şub Mar Nis Mayıs Haz Tem Ağu Eyl Eki Kas Ara şimdi 1 dakika önce $$1$$ dakika önce 1 saat önce $$1$$ saat önce Dün $$1$$ gün önce $$1$$ hafta önce 5 haftadan daha önce Takipçiler Takip Et THIS CONTENT IS PREMIUM Please share to unlock Copy All Code Select All Code All codes were copied to your clipboard Can not copy the codes / texts, please press [CTRL]+[C] (or CMD+C with Mac) to copy